FC2ブログ
ヽ|∵|ゝ(Fantom) の 開発blog? ホーム » トラブルシューティング »【ADT】【Eclipse】なぜか ADT を更新できない

【ADT】【Eclipse】なぜか ADT を更新できない  


 どうも最近色々な本を見ていても、ツールが無かったり、試したりできないものがあるので、ADT をまるごと更新することにした。
しかし、最新版(掲載時点:22.3.0)をインストールした後、起動すると下のエラーが出た。

「This Android SDK requires Android Developer Toolkit version 22.6.1 or above.
Current version is 22.3.0.~」

 「ヘルプ」-「更新の確認」をしてみても、更新が確認できないと出て、アップデートできない。

 仕方がないので色々調べてみたら、次のようなやり方でできた。

1.「ヘルプ」-「新規ソフトウェアのインストール...」を開く。
2.「作業対象」のプルダウンから登録されてる「Android Developer Tools Update Site」(*)を選択。
3.「開発ツール」にチェックを入れ、「次へ」でウィザードにしたがって、更新をインストール。
4.Eclipse の再起動を促されるので、リブート。

(*)↓のURLのもの(http で上手く行かなければ https で)
http://dl-ssl.google.com/android/eclipse/
https://dl-ssl.google.com/android/eclipse/
※無ければ「使用可能なソフトウェア・サイト」に登録する
※メニューは日本語化してある。


 これで正常に使えるようになった。

 ちなみにこの後、エミュレータを起動しようとしたら、エラーもないのに、「プロジェクトのエラーを修正してくれ」みたいなダイアログが出たが、「プロジェクト」-「クリーン」をしたら、起動できるようになった。エラーがキャッシュされてるっぽい。たまに原因不明のエラーが出たときも、クリーンをすると直ることが良くある(笑)。


(関連記事)
【ADT】「android-support-v4」の競合(Version,Revision違い)の修正方法
【ADT】Eclipse がいきなり落ちる
【ADT】Eclipse に Javadoc を設定する


関連記事
スポンサーサイト



category: トラブルシューティング

thread: プログラミング

janre: コンピュータ

tag: トラブルシューティング  インストール 
tb: 0   cm: --


トラックバック

トラックバックURL
→http://fantom1x.blog130.fc2.com/tb.php/108-fa116ebc
この記事にトラックバックする(FC2ブログユーザー)

プロフィール

Social

検索フォーム

全記事一覧

カテゴリ

ユーザータグ

最新記事

リンク

PR